Barracuda Icon
Chat
Live Chat

Hi, I'm Rosa.
How may I help you?

How may I help you?

Click below to send us a Message

Support

A global support network of experts.
At your service.

Back to Knowledgebase

User is not permitted to run searches on AOneSearch

Solution #00007312

Scope:
ArchiveOne Enterprise, v6.0 or later.

Answer:
SYMPTOMS
When a user runs a search from the Archive Search website, no results are returned. The user however can see their folder hierarchy and message previews successfully. The following can be seen in the ArchiveOne service trace:
27 11:37:14 726077 @DCOM020d1a00 CAMComplianceServer::SearchIndex NetGetAnyDCName for 'MY_DOMAIN_NAME' failed 1355
27 11:37:15 836883 @DCOM020d1a00 CAMComplianceServer::Search NetUserGetInfo for 'MyUser' returned '1722'
27 11:37:15 839569 @DCOM020d1a00 CAMComplianceServer::GetSid LookupAccountName failed error 1722
27 11:37:15 841293 @DCOM020d1a00 CAMComplianceServer::CheckUser query.mailbox_str_arr.GetCount 2
27 11:37:15 845738 @DCOM020d1a00 AOneMailboxManagerDatabase::GetUser Failed to find user
27 11:37:15 847502 @DCOM020d1a00 CAMComplianceServer::CheckUser returning 0
27 11:37:15 849183 @DCOM020d1a00 SearchIndex User not allowed to search.

ROOT CAUSE
ArchiveOne is unable to locate a domain controller for the specified domain.

RESOLUTION
The error implies that there is a connectivity issue between the ArchiveOne server and the domain controller(s). You should check network connectivity and ensure a suitable domain controller is online.

Link To This Page:
https://www.barracudanetworks.com/kb?id=50160000000uNvS